Facing error with Default Configuration Option in openam

you must understand by watching these logs from the configuration window

07/24/2023 01:43:42:684 PM UTC: Checking license acceptance...
07/24/2023 01:43:42:685 PM UTC: License terms accepted.
07/24/2023 01:43:42:685 PM UTC: Checking configuration directory /opt/tomcat/openam.
07/24/2023 01:43:42:685 PM UTC: ....Failed. Found existing config data.

Base directory specified :/opt/tomcat/openam cannot be used - has preexisting config data., refer to install.log under /opt/tomcat/openam/var/install.log for more information.

Error as show in following image:

Hey @hakxcore,

Based on the log message, it looks like the directory “/opt/tomcat/openam” already has some data. This could be possible if you had previously tried to install AM in the same location.

If you want a new installation, you can try to install openam in a different directory using the “Custom configuration” option, or delete the configurations found in /opt/tomcat/openam folder and try installing again.


Thankyou So Much, Your guidance helped me first I have added domain to my instance then done this to resolve the issue

rm -rf /opt/tomcat/openam
rm -rf /opt/tomcat/works/Catlina
systemctl daemon-reload
systemctl restart tomcat

it worked for me :)