Openidm7.4.0 mySQL8.0 connectivity

Hello everyone,

I am trying to configure MySQL with OpenIDM version 7.4.0 and am encountering some issues.

Here are the steps I have followed so far:

  1. Connector Addition: I have added the MySQL connector (mysql-connector-java-8.0.23) by copying the mysql-connector-java-8.0.23.jar file to the openidm/lib directory.
  2. Configuration Updates: I updated the conf/repo.ds.json and conf/repo.init.json files with the MySQL server details and the necessary tables for saving the data.
  3. MySQL Server Setup: I configured the MySQL server, created a new user named openidm, and granted the necessary access to this user.

Despite these steps, when I create a new user, the user details are not being saved in the managed_user table in MySQL. The user details appear in the user list in the web UI but are missing from the MySQL table.

I have also tried adding the FINE debug option for MySQL but am not receiving any failure logs.

Has anyone faced a similar issue or have any insights on what might be going wrong?

Any help or suggestions would be greatly appreciated.

Thank you!


Remove repo.ds.json, copy instead the repo.jdbc.json file from the db/mysql/conf folder, use the scripts in the script/ folder to configure the database, configure as well the default data source. And as always best way please follow the instructions in the documentation. MySQL repository :: IDM 7.5.0


1 Like


Thanks for your reply.

I tried to follow the same steps and here is the issue log.

export OPENIDM_OPTS=“-Xmx1024m -Xms1024m -Dopenidm.repo.port=3306”
anees@anees-Latitude-3400:~/Downloads/openidm$ ./
Executing ./…
Using OPENIDM_HOME: /home/anees/Downloads/openidm
Using PROJECT_HOME: /home/anees/Downloads/openidm
Using OPENIDM_OPTS: -Xmx1024m -Xms1024m -Dopenidm.repo.port=3306
Using LOGGING_CONFIG: -Djava.util.logging.config.file=/home/anees/Downloads/openidm/conf/
→ [22] Jun 04, 2024 1:26:57.302 PM org.forgerock.openidm.datasource.jdbc.impl.JDBCDataSourceService lambda$initDataSourceService$1
WARNING: Unable to establish connection: d69ed82e-be60-4ea6-9a1b-ab8756319806 - Connection is not available, request timed out after 60002ms., next attempt at Tue Jun 04 13:27:02 IST 2024


Describe specifically how you accomplished your #3.


It could be the connector version. I noticed that you are using connector version 8.0.23. According to the documentation @patrick_diligent referenced, in Step 1, it states to download MySQL Connector/J version 8.0 or later. However, there is an important note that cautions against using Connector/J versions 8.0.23 through 8.0.25. Here’s why.

I hope this helps