Customizing UI via Yarn not getting applied in AM ( in dev server it works )

Hello,

I’m having a little bit of trouble while trying to customize the UI via Yarn. To give you more context i was using the documentation ui-customization-guide/ui-testing-deploying and follow through all the steps.

  • in the Themconfiguration.js i have added the dark theme to apply it to the UI ( i could give you the code if needed)
  • When i do the Yarn start cmd and access the UI development server openam.example.com:8081/openam/XUI/#login i get the dark theme which is expected…success!
  • When i do the yarn build cmd and i try to access the openam.example.com:8080/openam/XUI/#login the theme doesn’t get uploaded for some reason which i can’t identify ( tried different browser, incognito mode, clear cache and so forth )
  • i checked the package.json file and the build script is present ( “scripts”: { “build”: “webpack --config config/webpack/configurations/production.js”
  • if i understood correctly from the guide once i do the yarn build cmd yarn builds directly into tomcat/webapps/XUI and deploys right ? or do i need to do another step? quote "5. Once you are satisfied with the changes, deploy the output in the build directory to the /path/to/ tomcat/webapps/openam/XUI/ directory of your AM instances. "

i believe what i am missing is this step on how to do the deploy the output in the build directory to the /path/to/tomcat/webapps/openam/XUI/

One way to get things working would be to run mvn clean install and then grab the ui-user zip file from the target folder and unzip that to the XUI folder under Tomcat.

1 Like

Hey Peter , have you tried this approach and worked yourself?